Encrypting Models

- Encryption
- Migrate Command
- Importing Data from MATLAB
- Exporting Data to MATLAB
News In Preview

This newsletter's Q and A section describes a common installation problem, the necessity to install using Administrator status. It also discusses how to arrange for multiple component footprints in the PCB netlist.

The Easily Overlooked Feature section describes the use and maintenance of the Shortcut keys.

The first article describes the encryption and decryption feature of Micro-Cap and explains how it can be used to protect proprietary intellectual property.

The second article describes the Migrate command which is used to transfer over all of your data files from an earlier version.

The third article describes how to import waveforms or curves of data from MATLAB or from any program that can generate a text file.

The fourth article describes how to export Micro-Cap waveforms or curves to MATLAB.

Contents

News In Preview .................................................................................................................................................. 2
Book Recommendations .................................................................................................................................... 3
Micro-Cap Questions and Answers .................................................................................................................. 4
Easily Overlooked Features ............................................................................................................................ 5
Encryption ........................................................................................................................................................... 6
Migrate Command .............................................................................................................................................. 9
Importing data from MATLAB ...................................................................................................................... 14
Exporting data to MATLAB ........................................................................................................................... 18
Product Sheet .................................................................................................................................................... 20
Book Recommendations

General SPICE


MOSFET Modeling

Signal Integrity

Micro-Cap - Czech

Micro-Cap - German

Micro-Cap - Finnish

Design


High Power Electronics


Switched-Mode Power Supply Simulation

Micro-Cap Questions and Answers

**Question:** I am having trouble installing my new Micro-Cap 11. It seems to install the main Micro-Cap files but has trouble even launching the HASP driver (haspdinst.exe). When it finishes with an error message, I can see the Micro-Cap folder but I can't run Micro-Cap because it says it can't find the key.

**Answer:** There are several possible problems but the most likely answer is that you are probably installing under non-administrator (admin) status and the OS may be setup to require admin status in order to install the HASP driver (haspdinst.exe). The HASP driver adds a device driver so it has more potential for causing security problems, so some organizations arrange the OS to require admin status to do this.

Try gaining admin status and retry the whole installation again. If you install outside the Program Files folder (which we strongly recommend) you shouldn't need to run Micro-Cap under admin status, but you probably need to install it that way.

**Question:** I want to generate a PADS netlist. I want to control the footprint name using the PADS box in the package editor. This is working OK for most parts, but I have a problem with resistors and capacitors. I have to create a part with a model for the various resistor and capacitor footprints I want to use. How can I create a library for my custom resistors so I can make a part so I can associate a PADS footprint with the part?

**Answer:** Create a new resistor part type in the Component library and then create a listing in the Package library defining its package type. When you place this resistor in a schematic, MC11 automatically assigns its PACKAGE attribute using the Package library entry. The PADS netlist is generated using the part's PACKAGE attribute shown in the Attribute dialog box.

You may need to create several components to accommodate the different footprints.
Easily Overlooked Features

This section is designed to highlight features that may be overlooked among the many capabilities of Micro-Cap.

Using the Shortcut keys
Did you know that you can select the Tool bar component types with a single key? The Tool bar contains twelve of the more commonly used components and each is assigned a single key. Here are the keys:

Ground  G
Resistor  R
Capacitor  C
Inductor  L
Diode  D
NPN  Q
MOSFET  M
OPAMP  O
Battery  B
Current Source  I
Voltage Source  V

Pressing R for instance, changes the mode to Add Component and selects Resistor as the component to be added. Pressing V selects the Voltage Source.

These keys and any other shortcut keys can be changed or assigned by using the dialog box at:

Preferences (CTRL+ALT+P) / Shortcuts

This lets you select a menu item or Tool bar icon and assign to it a shortcut key of your choice.
Encryption

Micro-Cap 11 can encrypt not just macros, but library files as well. Most commercial modeling is done in the form of subcircuits which are saved in text files. Here, for example, is a portion of the analog.lib provided by Spectrum Software as a part of the Analog Libraries:

```
* TAM / ADSC
*
* Node assignments
  * noninverting input
  * | inverting input
  * | positive supply
  * | negative supply
  * | output
  * |  |  |  |
.SUBCKT 86N2275_AD 1 2 99 50 45
*
* INPUT STAGE
*
C1 4 3 5 50NIX
C2 6 2 7 20NIX
R1 99 11 1KE3
R2 99 12 15E3
RE1 5 8 1K3
RE2 7 8 1K3
EOS 3 1 POLY(2) | (61,90) (73,90) 1E-3 1.78E-5 1
IDS 1 2 5E-9
ECMH1 4 11 POLY(1) | (99,50) 0.9 -30E-3
ECMH2 6 12 POLY(1) | (99,50) 0.9 -30E-3
ECML1 9 50 POLY(1) | (99,50) 0.1 30E-3
ECML2 10 50 POLY(1) | (99,50) 0.1 30E-3
D1 9 5 DX
D2 10 7 DX
D3 13 1 D3
D4 2 13 D2
IDIAS 6 50 200K-6
*
* CMRR=115 dB, ZERO AT 1kHz, POLE AT 10kHz
*
```

The file is not encrypted. You can see the contents and create a circuit diagram of the models. If you are a semiconductor manufacturer and these models describe what you feel is proprietary to your company, you might want to encrypt them to protect your intellectual property. Here is how you would go about encrypting the file.

1) Load the file using the File Load command.

2) Select the File menu Encrypt / Decrypt option. That invokes this dialog box.

![Encrypt File dialog box](image)
To encrypt the file simply enter a password. Enter it again to be sure that the password you want to use is entered. Click on the OK button. Micro-Cap encrypts the critical portions, leaving the header intact. This is done so that you can see the pin names and any possible parameters used by the subcircuits. The encrypted file is saved to disk. It looks like this:

```
%SUBCRT_S8M2275_AD

%BEGIN.Profile

@SUBC 1

@SUBCRT_S8M2275_AD

* Node assignments

+ noninverting input
  + inverting input
  + positive supply
  + negative supply
  + output

.*
```

The critical parts of the subcircuit have been encrypted leaving the comments and the .subckt line intact. That way you can see the pin names (which are needed when the part is entered into the Component library) and parameters (which are needed when you place the part in a schematic), and the comments (which are helpful in understanding the pin functions and parameters).

When Micro-Cap analyzes a schematic containing an encrypted part, it decrypts it and parses the contents just as it would for an un-encrypted part. The contents just never get displayed.

To decrypt a library file, load it, then select the Encrypt / Decrypt item from the File menu. Enter the password. Click OK. The program decrypts the entire file, saves it to disk, and displays the file in plain text.
Macros are handled somewhat differently because it is necessary for the user to be able to view partially encrypted library files but not so with encrypted macro files.

To encrypt a macro, do this:

1) Load the macro file using the File Load command.
2) Select the File menu Encrypt / Decrypt option.
3) Enter the desired password twice.
4) Click on the OK button.

The program encrypts the macro file, saves it to disk, and removes the file from memory. If you subsequently load the file, the program will ask for the password. If you enter the password correctly, the program displays the file. It does NOT save the decrypted file to disk. To do that you must use the File menu Save or Save As command.

To decrypt an encrypted macro file do this:

1) Load the macro file using the File Load command.
2) Enter the password.
3) Optionally use the Save command to save the decrypted file to disk.
Migrate Command

When upgrading to a new version of Micro-Cap, the user will typically want to import data from their previous version of Micro-Cap. The type of data may consist of files such as schematics, macro circuits, and libraries, schematic information for components, shapes, and packages, or user defined settings and preferences. The following sections will provide tips and methods for how to make a smooth upgrade between versions of Micro-Cap.

Installation Location

_Do not install Micro-Cap 11 in the same folder as a previous version of Micro-Cap._ Install Micro-Cap 11 in a new folder. This folder may be located anywhere on the hard drive. Installing in the same folder as a previous version could overwrite files that may still be needed for specific simulations. It may even prevent a user from being able to run the older version if necessary. Keeping the older version in a separate directory provides a nice, simple backup as Micro-Cap 11 will convert files to an updated format when they are loaded in the program.

Migrate Wizard

Migrate is available as a command under the File menu. The Migrate wizard provides a method that lets you migrate selected files from an earlier version of Micro-Cap. After you specify the location of an older MCAP.DAT file, MC11 reads it and makes a list of appropriate files that can be optionally copied to suitable Micro-Cap 11 locations. The migration process will have options to bring over user settings, component, shape, and package information, library files, and macro files. Upon launching the Migrate wizard, the dialog box below will appear.

![Migrate Choose Drives](image)

*Fig. 2 - List of devices for searching for candidate mcap.dat files*

Micro-Cap performs a quick scan for available devices (typically hard drives but may also be USB keys or memory devices). Select the device containing the older Micro-Cap installations.
Micro-Cap performs a quick scan of the selected devices for previous MCAPDAT files (MC5.DAT if upgrading from Micro-Cap 5) in common locations and presents the choices in a dialog box that looks like this:

**Fig. 2 - Migrate File dialog box**

If the .DAT file that you want to use is not shown in the list, use the Browse feature or manually type in the path and file name. Select or input the .DAT file from the version that you want to migrate from. Click Next. The dialog box in Figure 3 will appear which gives you the option to select which user settings, component, shape, package, library, or macro files to migrate over.

**Fig. 3 - List of files that can be migrated over**

which user settings, component, shape, package, library, or macro files to migrate over.
The controls and options for this dialog box are as follows:

**Select All**
This button selects all of the displayed files.

**Clear All**
This button de-selects all of the displayed files.

**How to handle shapes and components with matching names but different content**
When merging shape and component files, it is possible that incoming names match names already in the library. This option lets you decide how to handle these cases. You have three choices:

- **Replace**
  This replaces the existing item with the older incoming item. You might use this option if you have, say, changed the ground shape and want to retain it.

- **Discard**
  This does not import the item.

- **Add with similar name**
  This imports the item but saves it under a similar, but slightly different name. This makes it available, but gives preference to the standard MC11 shape or component.

The default for this option is Discard.

The list of displayed files is broken up into the following sections: User Settings, Shapes, Components, Packages, Macros, and Libraries. A check mark in the check box enables that specific file for migration. The checkbox for the section headers will enable/disable all files for the section.

**User Settings**
The User Settings section displays the .DAT file that was selected. Enabling the .DAT file for migration will transfer general program information for Micro-Cap including default colors and fonts, toolbar settings, and Preferences option settings and values.

**Shapes, Components, and Packages**
If you are migrating component files over to MC11, and have created your own shapes for these components in the previous version of Micro-Cap, then you must also migrate the corresponding shape files. Otherwise, the shape that your component references will not exist in MC11 and you will get a default shape such as a battery. Similarly, when migrating packages, the corresponding component files also need to be migrated.

For .Cmp, .Shp, and .Pkg files:

1) For entries that do not match a name in the current version the Migrate wizard will take all entries from the previous version and merge them into the corresponding file.

2) For entries that match a name in the current version the Migrate wizard will replace, discard, or add with a similar name according to the choice made in the How to handle shapes and components with matching names but different content section above.
Macro Files
For macro files, the Migrate wizard will scan all folders referenced in the Model Library field of the Paths dialog box in the previous version to find all files with the extensions .MAC that do not match a name of a macro file currently in MC11. Depending on the location of the macro files, there are a few things that may happen to the macro files. Because some users still use the older .CIR extension for macro files, the Migrate wizard will do the same for all files with the extensions .CIR found in Model Library folders.

If the macro is in the normal Library folder of the old version, then Migrate will copy that over to the Library folder of Micro-Cap 11.

If the macro is in a subdirectory off of the main Micro-Cap folder of the old version, then Migrate will create this subdirectory under the Micro-Cap 11 folder if needed and copy the macro file over to it.

If the macro is in a directory not off of the main Micro-Cap folder of the old version, then Migrate will leave the macro in that location.

For the last two cases with the macro, the path to these directories containing the macro files would need to be manually added into the Model Library field in the Paths dialog box in MC11. The Paths dialog box can be accessed under the File menu.

Library Files
For library files, the Migrate wizard will scan the Nom.lib file of the old version, and add to the Nom.lib file in Micro-Cap 11 any files that are not currently referenced. Depending on the location of the library files, there are a few procedures that may happen to the actual library files.

If the file is in the normal Library folder of the old version, then Migrate will copy that over to the Library folder of Micro-Cap 11.

If the file is in a subdirectory off of the main Micro-Cap folder of the old version, then Migrate will create this subdirectory under the Micro-Cap 11 folder if needed and copy the library file over to it. For example, if the MyNPN.Lib file was stored in a folder such as C:\MC9\MYLIB\ then Migrate would create a folder called MYLIB under the MC11 folder (unless it already exists) and copy the MyNPN.LIB file over to that folder. This path would then be hardcoded into the MyNPN.Lib reference in the MC11 Nom.lib.

If the file is in a directory not off of the main Micro-Cap folder of the old version, then Migrate will leave the file in that location. The library file will have this path hardcoded into its reference in the MC11 Nom.lib file. For example, if the ADiodes.Lib file was stored in a folder such as D:\MYPARTS\ then Migrate would leave the library file in that folder and add the reference .lib "D:\MYPARTS\ADiodes.Lib" into the MC11 Nom.lib file.

Upon clicking Next on this screen, the selected actions will be run and the information migrated to MC11. A results screen will appear that summarizes the migration operation such as the one in Figure 4.
The Migrate operation does not deal with all possible Micro-Cap files. The following groups of files need to be manually transferred.

**Circuit Files**
The circuit files should be transferred over to the data directory of Micro-Cap 11. The data directory will be specified in the Data field of the Path dialog box under the File menu. The default data path upon installation will be:

```
<drive>:\MC11\DATA\
```

The conversion of a schematic file to the new Micro-Cap 11 format will occur when the file is initially loaded into Micro-Cap 11 but will only be permanently converted when the schematic file is saved. For those users who need to convert a schematic back to an older format, the File menu contains a Translate option that will let a schematic file be converted into an older Micro-Cap format.

**User Definitions**
The User Definitions are stored in the MCAPINC file (DEF.MC5 for Micro-Cap 5) that resides in the main Micro-Cap directory. This file is easily accessible by going to the Options menu and selecting User Definitions. This file contains user defined command statements that will automatically be included whenever a simulation is entered. Typically, the command statements are .define statements but other statements are also valid. The easiest method for transferring this information is through a copy and paste operation. Load both the old and new MCAPINC files in a text editor or their respective versions of Micro-Cap. Then just copy and paste the information that needs to be transferred. If none of the command statements in the installed MCAPINC are of interest, then the file can also be overwritten.

**Miscellaneous Files**
There are other files that may need to be brought over to Micro-Cap 11, but that may not be crucial in running most simulations. These files should be copied to the appropriate library or data directory. Files such as Model (.MDL) or filter impedance files (.RES, .IND, .CAP) should be placed in the library directory. Files such as State Variable (.TOP), S Parameter (.S2P), User Source (.USR), or Digital File Stimulus files (.STM) should be placed in the data directory.
Importing data from MATLAB

Importing data from Excel, MATLAB, or any program that can create a text file is relatively easy. The steps in the process are these:

1) Run the MATLAB program that creates a table of values and saves it in a text file.
2) Edit an existing User Source data file to have the correct headers.
3) Copy the generated data into the User Source data file from 2). Rename the user source file.
4) In your circuit, add a plot of the User Source data file.
5) Run the Micro-Cap analysis and you'll see a plot of the data from the user file.

Here is an example of the sequence:

1) Run the MATLAB program that creates a table of values and saves it in a text file.

Here is a MATLAB program that generates a file called mc11_test.txt containing a table of values T and EXP(T).

```matlab
% create a matrix y, with two rows
x = 0:0.01:1;
y = [x; exp(x)];

% open a file for writing
fid = fopen('mc11_test.txt', 'w');

% print a title, followed by a blank line
fprintf(fid, 'Time V(OUT)\n
');

% print values in column order
% two values appear on each row of the file
fprintf(fid, '%f  %f\n', y);
fclose(fid);

% create a matrix y, with two rows
x = 0:0.01:1;
y = [x; exp(x)];

% open a file for writing
fid = fopen('mc11_test.txt', 'w');

% print column headers, followed by a blank line
fprintf(fid, 'Time V(OUT)\n
');

% print values in column order
% two values appear on each row of the file
fprintf(fid, '%f  %f\n', y);
fclose(fid);
```
If you run this file in MATLAB it will create the text file mc11_test.txt, which contains this:

Time V(OUT)

0.000000  1.000000
0.010000  1.010050
0.020000  1.020201
0.030000  1.030455
...
0.970000  2.637944
0.980000  2.664456
0.990000  2.691234
1.000000  2.718282

2) Edit an existing User Source data file to have the correct headers.

Start with any user file (*.usr). For example, here is the Sample.usr file from the USER.CIR sample circuit file.

[Main]
FileType=USR
Version=2.00
Program=Micro-Cap

[Menu]
;Simple   = T,X,Y
;SimpleNoX= T,Y
;Complex  = F,Xr,Xi,Yr,Yi
;ComplexNoX= F,Yr,Yi
;FormatType = Simple | Complex | SimpleNoX | ComplexNoX
;Format=FormatType
WaveformMenu=label vs T

[Waveform]
Label=label vs T
MainX=T
LabelX=T
LabelY=label vs T
Format=Simple
Data Point Count=256
0,0,0
3.921568627E-009,3.921568627E-009,0
7.843137255E-009,7.843137255E-009,0
1.176470588E-008,1.176470588E-008,0
...

Edit the header so that it looks like the following. You can use any text editor including Micro-Cap to edit the text.
3) Copy the generated data into the User Source data file from 2). Rename the user source file.

Here we copy the waveform data from the mc11_test.txt text file and paste it to the table area of the User Source file from step 2) so that it now looks like this:

```plaintext
[Main]
FileType=USR
Version=2.00
Program=Micro-Cap

[Menu]
;ComplexNoX= F,Yr,Yi
;FormatType = Simple | Complex | SimpleNoX | ComplexNoX
;Format=FormatType
WaveformMenu=V(OUT) vs T

[Waveform]
Label=V(OUT) vs T
MainX=T
LabelX=T
LabelY=V(OUT) vs T
Format=SimpleNoX
Data Point Count=102

<table>
<thead>
<tr>
<th>Time</th>
<th>V(OUT)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.000000</td>
<td>1.000000</td>
</tr>
<tr>
<td>0.010000</td>
<td>1.010050</td>
</tr>
<tr>
<td>0.020000</td>
<td>1.020201</td>
</tr>
<tr>
<td>...</td>
<td></td>
</tr>
<tr>
<td>0.980000</td>
<td>2.664456</td>
</tr>
<tr>
<td>0.990000</td>
<td>2.691234</td>
</tr>
<tr>
<td>1.000000</td>
<td>2.718282</td>
</tr>
</tbody>
</table>

Rename the modified user file to something like mc11_test.usr.
4) In your circuit, add a plot of the User Source data file.

In your circuit, add a plot. Use T in the X Expression field. In the Y expression, right click in the field and select the Curve option and then the Curve Y option. Specify the User Source file name and Expression name used in 2). Your analysis limits should look like this:

![Fig. 5 - Transient analysis limits dialog box](image)

Here we have added the plot of EXP(T) for a comparison check:

5) Run the Micro-Cap analysis and you'll see a plot of the data from the user file.

Here is what the analysis plot looks like:

![Fig. 6 - Transient plot showing the imported MATLAB curve](image)
Exporting data to MATLAB

Exporting data to MATLAB is also relatively easy. The steps in the process are these:

1) Run Micro-Cap and create a numeric output file with the curve or waveform you want in a text file. Typically this will be a file named Mycircuit.tno or Mycircuit.ano for AC analysis. You must save the waveform or curve in 'bare' format which means a table with data only; no extraneous text including headers. Here are the necessary settings for the Properties (F10) / Numeric Output panel.

![Fig. 7 - Transient plot numeric output settings to create 'bare' waveform table](image)

2) Run the analysis.

3) Press F5 to view the Numeric Output file.

4) Press F10. Specify Not Spice. This eliminates the extra line at the bottom of the text file, "Spicetype=PSpice".

5) Save the output file as Myfile.out to make it distinct from the Myfile.tno file.
6) Run MATLAB. Type in these statements:

```matlab
load c:\mc11\data\Myfile.out
x = Myfile(:,1);
y = Myfile(:,2);
Plot(x,y)
```

You'll see a MATLAB plot displayed in a separate window that looks something looks this:

![Fig. 8 - MATLAB plot of Micro-Cap waveform data](image)

This procedure is derived from a tutorial at:

http://web.cecs.pdx.edu/~gerry/MATLAB/plotting/loadingPlotData.html#loadCommand

You can consult this tutorial for more information.

A more elaborate procedure that can accept column names is described here:

http://www.tutorialspoint.com/matlab/matlab_data_import.htm
Product Sheet

Latest Version numbers
Micro-Cap 11 .................................................................Version 11.0.0.7
Micro-Cap 10 .................................................................Version 10.1.0.3
Micro-Cap 9 .................................................................Version 9.0.9.0
Micro-Cap 8 .................................................................Version 8.1.4.0
Micro-Cap 7 .................................................................Version 7.2.4

Spectrum’s numbers
Sales .................................................................................(408) 738-4387
Technical Support ..........................................................(408) 738-4389
FAX .................................................................................(408) 738-4702
Email sales ........................................................................sales@spectrum-soft.com
Email support ....................................................................support@spectrum-soft.com
Web Site ...........................................................................http://www.spectrum-soft.com